summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorBen Bridle <bridle.benjamin@gmail.com>2023-11-26 10:17:03 +1300
committerBen Bridle <bridle.benjamin@gmail.com>2023-11-26 10:17:03 +1300
commitcbc6f89f34abab7e749e9382333ea0b0f82a06dc (patch)
treec66663267e3fefb0376c83af114075f06a5db6ca /Cargo.toml
parentafa81e9ae6a56efe2eae2990e09c672b74328715 (diff)
downloadbedrock-asm-cbc6f89f34abab7e749e9382333ea0b0f82a06dc.zip
Shrink and strip compiled binary in release mode
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 7 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1bc614d..3ffc706 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -6,3 +6,10 @@ edition = "2021"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
+
+[profile.release]
+lto=true
+opt-level="s"
+debug=false
+strip=true
+codegen-units=1