summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorBen Bridle <ben@derelict.engineering>2025-03-25 12:46:49 +1300
committerBen Bridle <ben@derelict.engineering>2025-03-25 12:48:49 +1300
commitab84ad75629b0a4124221023ca91411d2cd62a32 (patch)
tree0c333f06bec5270084aaec71cf173c798420207b /Cargo.toml
parent07ae3438917fd854a46924a410f6890cd0651f1b (diff)
downloadbedrock-pc-ab84ad75629b0a4124221023ca91411d2cd62a32.zip
Restructure program
This commit also includes changes to devices according to the latest devices specification, in particular the math and system devices.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml9
1 files changed, 5 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 448a71f..bfad173 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -6,18 +6,19 @@ edition = "2021"
description = "Emulator for running Bedrock programs"
[dependencies]
-bedrock-asm = { git = "git://benbridle.com/bedrock-asm", tag = "v4.0.6" }
-bedrock-core = { git = "git://benbridle.com/bedrock-core", tag = "v5.0.0" }
+bedrock-asm = { git = "git://benbridle.com/bedrock-asm", tag = "v5.0.0" }
+bedrock-core = { git = "git://benbridle.com/bedrock-core", tag = "v5.1.0" }
phosphor = { git = "git://benbridle.com/phosphor", tag = "v3.2.2" }
geometry = { git = "git://benbridle.com/geometry", tag = "v1.0.0" }
-log = { git = "git://benbridle.com/log", tag = "v1.1.1" }
-switchboard = { git = "git://benbridle.com/switchboard", tag = "v1.0.0" }
+log = { git = "git://benbridle.com/log", tag = "v1.1.2" }
+switchboard = { git = "git://benbridle.com/switchboard", tag = "v2.1.0" }
chrono = { version = "0.4.38" }
[target.'cfg(target_os = "windows")'.dependencies]
windows = { version = "0.58.0", features = ["Win32_Storage_FileSystem"] }
+
[profile.release]
lto=true
opt-level="s"