summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 5 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index b1408ce..7b07fdb 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -5,7 +5,6 @@ authors = ["Ben Bridle"]
edition = "2021"
description = "Emulator for running Bedrock programs"
-# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
bedrock_core = { git = "git://benbridle.com/bedrock_core", tag = "v3.0.1" }
@@ -15,6 +14,11 @@ geometry = { git = "git://benbridle.com/geometry", tag = "v1.0.0" }
mini_paste = "0.1.11"
time = { version = "0.3.30", features = [ "local-offset" ] }
+
+[target.'cfg(target_os = "windows")'.dependencies]
+windows = { version = "0.58.0", features = ["Win32_Storage_FileSystem"] }
+
+
[profile.release]
lto=true
opt-level="s"