diff options
author | Ben Bridle <bridle.benjamin@gmail.com> | 2024-10-19 18:20:09 +1300 |
---|---|---|
committer | Ben Bridle <bridle.benjamin@gmail.com> | 2024-10-19 18:21:48 +1300 |
commit | 990f2b310bfecf2e04a8a462f6939833080c62bf (patch) | |
tree | bbbbb65a3cfcbaec71935b581e7162a28947f960 /Cargo.toml | |
parent | 824483fc95ccbc4627d07371bac8ed4da44c83e7 (diff) | |
download | phosphor-990f2b310bfecf2e04a8a462f6939833080c62bf.zip |
Complete rewrite of Phosphor
The previous version of the library passed events to an implementation
of a WindowController trait by calling the trait method associated with
each event, and received requests by calling different trait methods and
reading the returned values. This had the downside of requiring that any
data received from one event had to be stored in the type so that it
could be passed back to Phosphor when a request method was called.
The new library structure uses a single handle_event method on a trait,
which is passed data representing any single event when it is called.
Data is returned via a passed mutable reference to an EventQueue,
meaning that any number of responses for any event can be immediately
returned to Phosphor without having to wait in storage.
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 9 |
1 files changed, 5 insertions, 4 deletions
@@ -1,6 +1,6 @@ [package] name = "phosphor" -version = "2.0.0" +version = "3.0.0-rc1" authors = ["Ben Bridle"] edition = "2021" description = "Window management library" @@ -8,11 +8,12 @@ description = "Window management library" # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html [dependencies] -buffer = { git = "git://benbridle.com/buffer", "tag" = "v1.0.0" } +buffer = { git = "git://benbridle.com/buffer", "tag" = "v1.1.0" } +event_queue = { git = "git://benbridle.com/event_queue", "tag" = "v1.1.0" } geometry = { git = "git://benbridle.com/geometry", "tag" = "v1.0.0" } -softbuffer = "0.3.1" -winit = { version = "0.28.1", default-features=false } +softbuffer = "0.4.6" +winit = { version = "0.30.5", default-features=false, features=["rwh_06"] } [features] default = ["x11", "wayland"] |