summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorBen Bridle <bridle.benjamin@gmail.com>2023-10-11 08:21:10 +1300
committerBen Bridle <bridle.benjamin@gmail.com>2023-10-11 08:21:10 +1300
commit8e08d723ff7a853f2b10dc0f1408911d5801cea8 (patch)
tree50efd2967e93f8bc1009f242a405ec18335f0aa6 /Cargo.toml
parenta6e97019bd53e4478c846f8f636c18ecb53bece2 (diff)
downloadphosphor-8e08d723ff7a853f2b10dc0f1408911d5801cea8.zip
Rewrite phosphor
This has been a long-awaited task, the code has been accumulating small changes for a while now. This commit consolidates all these changes in order to make the code more readable and maintainable for the future. Notable changes: - Remove the concept of a ProgramController - Remove all of the dead OpenGL stub code - Update winit to version 28.1, from 27.4 - Use softbuffer for writing pixels to the native display server
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml12
1 files changed, 4 insertions, 8 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1aac11d..ed6c28b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -6,12 +6,8 @@ edition = "2021"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
-winit = { version = "0.27.4", default-features = false, features = ["x11"] }
-x11-dl = "2.19.1"
-raw-window-handle = "0.4.2"
-# raw-gl-context = "0.1.2"
-# gl = "0.14"
-
-geometry = { path = "/home/ben/Libraries/geometry" }
-nosferatu = { path = "/home/ben/Libraries/nosferatu" }
buffer = { path = "/home/ben/Libraries/buffer" }
+geometry = { path = "/home/ben/Libraries/geometry" }
+
+softbuffer = "0.3.1"
+winit = { version = "0.28.1", default-features = false, features = ["x11"] }