summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml9
1 files changed, 5 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 3a45b37..35cbfaa 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "phosphor"
-version = "2.0.0"
+version = "3.0.0-rc1"
authors = ["Ben Bridle"]
edition = "2021"
description = "Window management library"
@@ -8,11 +8,12 @@ description = "Window management library"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
-buffer = { git = "git://benbridle.com/buffer", "tag" = "v1.0.0" }
+buffer = { git = "git://benbridle.com/buffer", "tag" = "v1.1.0" }
+event_queue = { git = "git://benbridle.com/event_queue", "tag" = "v1.1.0" }
geometry = { git = "git://benbridle.com/geometry", "tag" = "v1.0.0" }
-softbuffer = "0.3.1"
-winit = { version = "0.28.1", default-features=false }
+softbuffer = "0.4.6"
+winit = { version = "0.30.5", default-features=false, features=["rwh_06"] }
[features]
default = ["x11", "wayland"]