From b190726a783a4aae98fad6b8fcfb266cabc4eb79 Mon Sep 17 00:00:00 2001
From: Ben Bridle <bridle.benjamin@gmail.com>
Date: Wed, 8 Jan 2025 12:26:03 +1300
Subject: More robust file traversal logic

File traversal can now cope with symbolic links. The original path to
each file is preserved where before they were unintentionally
canonicalized, so the source folder prefix can now be correctly
stripped from the path of each source file.

This commit also adds the !folder syntax from the original toaster.
Directories with a !-prefix are copied without modification to the site
root.

A --delete option has been added to the program. When this option is
set, the destination directory is first deleted if it already exists.
---
 Cargo.toml | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

(limited to 'Cargo.toml')

diff --git a/Cargo.toml b/Cargo.toml
index 139574e..d83f0d4 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -4,7 +4,7 @@ version = "1.2.0"
 edition = "2021"
 
 [dependencies]
-vagabond = { git = "git://benbridle.com/vagabond", tag = "v1.0.1" }
+vagabond = { git = "git://benbridle.com/vagabond", tag = "v1.0.2" }
 markdown = { git = "git://benbridle.com/markdown", tag = "v2.1.0" }
 xflags = "0.4.0-pre.1"
 
-- 
cgit v1.2.3-70-g09d2